WP-Rakuten-Link 0.6 をリリース

0.6 をリリースしておきます。
専用ページを作っておきましたので、ダウンロードはこちらからどうぞー。

追記: 0.6.1 にアップデートしました。不具合の修正とか。

更新内容は、だいたい以下のような感じです。

不具合を修正して、新しい API バージョンを指定するようにし、管理画面のコードを一部書き直したり、モバイルに対応していたり、楽天ブックス(とりあえず本だけ)に対応したり、設定画面からキャッシュを削除できるようにしたりだなんて変更があります。

古いバージョンを使用している方は、アップデート推奨な気がします。これまでのものが割と酷かったので。

なお、バージョンアップ後に一度、設定画面を開いて再設定を行っておいてください。設定画面のコードを変更しているので、これをやらないと不具合が出ます。キャッシュファイルも一度消した方が良さそうです。

ちなみに今回のバージョンからは、楽天ブックスで書籍を扱えるようにしてあります。DVD やらゲームもやっておきたかったんですが、商品表示に掛かる API が全部別々になっているので、流石にめんどくさかったので対応していません。ワッハッハ。

Error: Suspended
Error: Suspended

WordPress の Plugin Directory には登録していない野良プラグインですから、自動アップデート通知なりは機能しません。つまり更新しても誰も気が付かないなんてことも有り得るわけですね。ワッハッハッハ。

そんなたいそうなプラグインでもありませんし、中身も中身なので、登録したらなんだか怒られちゃいそうな気がしちゃいますね。

  1. 思うに、CSS をもう少しまともなものにしたほうがいいような気がしてきた。

  2. まあ、さっそくバグが……。IMG タグが適切に閉じられていなかったので、これを修正。0.6.1 になりました。ダウンロードは専用ページからどーぞー。

    したついでに使用 API バージョンを最新(2010-06-30)に修正して、「あす楽」「キャッチコピー」にも対応しました。テンプレート挿入画面から指定できますので、お好みにあわせてどうぞ。

    この都合上、0.6.1 以前のキャッシュファイルは一度削除するようにしてください。以前のキャッシュファイルにはキャッチコピーや、あす楽の情報がありません。使わなければオッケーなはず。

  3. New post: WP-Rakuten-Link 0.6 をリリース ( http://blog.newf.jp/?p=986 )

    • RYURYU
    • 2010年 7月 10日 11:35pm

    便利なプラグインありがとうございます。
    早速インストールしてみたのですが、
    Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /home/frameflame/2han-pc.com/public_html/wp/wp-content/plugins/wp-rakuten-link/rakuten_link.php on line 65
    重大なエラーのため有効かできませんとでてしまいます。

    バージョンは3.5.1です。
    なにが考えられますか?
    初心者ですが教えていただけますでしょうか?

    • RYURYU さん

      はじめまして。うーん、それはおかしいですね。
      以下の点をご確認いただいてよろしいでしょうか。

      ・PHP のバージョンが 4.X ではないでしょうか。
      ・WordPress は今現在、3.5.1 というバージョンが存在しません。もしかして、2.5.1 でしょうか。

      ここは帰宅してから、ページに追記しますが、PHP 4.X は対応しません.WordPress についても、古いバージョンのサポートはできないです。

      もし、上記の条件に当てはまるようでしたら、サーバーの PHP を 5.x にして、WordPress を最新版にしてお試しください。

    • すいません。ダウンロードページ側が間違ってコメント受付状態になっていましたので、いただいたコメントはこちらに移動させていただきました。

    • RYURYU
    • 2010年 7月 11日 8:45am

    おはようございます!
    お返事ありがとうございます!

    PHPのバージョンが4になっていました・・・エックスサーバーなのですぐにバージョン5に変更しましたが、同じエラーがでてしまいます。

    あと、バージョン3.5.1はAtahualpaとかいうテーマのバージョンでした。
    申し訳ありません。

    WORDPRESS 3.0 日本語版がインストールされています。

    もう少しなんとかいじくってみます。

    ほかに原因がありましたら是非おしえてください。
    よろしくおねがいします。

    • RYURYU
    • 2010年 7月 11日 9:06am

    ありがとうございます!

    おかげさまで設置することができました!
    やっぱりPHPのバージョンが原因だったようです。
    助かりました!これからもがんばってください。
    ちょこちょこのぞかせていただきます!

    • 解決したようでなによりですー。

      PHP 4 と 5 とでは結構違いがありまして、もしかすると他に使用していたものに問題が出るかもしれません。最近のもの(WP 含)は問題ないハズですが。

  4. はじめまして。

    これは便利!と思い早速試してみたのですが、商品のリンクが切れてしまいますorz.

    そこで、rakuten_link.phpの中に記載してある、#Url#あたりのパスを書き換えていますが、
    うまく飛びません。

    なんとか、正しいリンクにできないものでしょうか。

    よろしくおねがいいたします。

    • もじもじさん

      サイト拝見しました。商品の飛び先(URL)自体が間違っているみたいですね。

      WP-Rakuten-Link の設定画面の「楽天アフィリエイトID」は正しく設定されていますか? 存在しないアフィリエイト ID が登録されてしまっていると、楽天のトップページにリダイレクトされてしまいます。

      ■楽天アフィリエイトIDの確認
      https://grp02.id.rakuten.co.jp/rms/nid/login?service_id=i11

      上記 URL で確認できる ID に入れ替えて動作を試してみてくださいー。
      (設定を変更したあとは、設定画面から「キャッシュを削除する」を選んでから確認してください。)

      • あ、スクリプト自体をどう変更されたかは分かりませんし、これはサポートができません。上記お試しになる際には、オリジナルバージョンに戻してからでお願いします。

      • にゆうふさん

        うほー!
        飛ぶようになりました!

        ありがとうございます!

        使いまくります

  1. トラックバックはまだありません。